الفرق بين المراجعتين لصفحة «مستخدم:Wafaa/Pandora Installation and Configuration Issues»
(←==) |
ط (نقل أحمد صفحة Wafaa/Pandora Installation and Configuration Issues إلى مستخدم:Wafaa/Pandora Installation and Configuration Issues دون ترك تحويلة: يبدو أنه كان القصد) |
||
| (34 مراجعة متوسطة بواسطة مستخدم واحد آخر غير معروضة) | |||
| سطر 1: | سطر 1: | ||
| − | + | <div dir="ltr"> | |
| + | |||
| + | '''Loading screen after installation:''' | ||
| + | |||
FIX→ | FIX→ | ||
| − | + | uninstall rabbitmq and install it again | |
| + | |||
| + | '''2- ImportError: No module named mongoengine.django.sessions (IN Terminal)''' | ||
| − | |||
FIX→ | FIX→ | ||
| سطر 12: | سطر 16: | ||
run ./bin/pip install -r requirements.txt | run ./bin/pip install -r requirements.txt | ||
| − | |||
| − | + | #''' ERROR: Site pandora does not exist! when run a2ensite pandora (Terminal) | |
| − | (step b) in README file for pandora installation tutorial in the wiki https://wiki.0x2620.org/browser/pandora/README) | + | (step b) in README file for pandora installation tutorial in the wiki https://wiki.0x2620.org/browser/pandora/README''') |
FIX→ | FIX→ | ||
| − | + | rename pandora.conf to be pandora.com /etc/apache2/sites-available | |
| − | then | + | |
| − | a2ensite pandora.com | + | cd /etc/apache2/sites-available |
| − | + | mv pandora.conf pandora.com | |
| + | |||
| + | then enable the new config file by running | ||
| + | a2ensite pandora.com | ||
| + | |||
| − | + | '''Syntax error on line 22 of /etc/apache2/sites-enabled/pandora.com: (Termial) | |
Invalid command 'ProxyRequests', perhaps misspelled or defined by a module not included in the server configuration | Invalid command 'ProxyRequests', perhaps misspelled or defined by a module not included in the server configuration | ||
Action 'configtest' failed. | Action 'configtest' failed. | ||
| − | The Apache error log may have more information ...fail | + | The Apache error log may have more information ...fail''' |
| − | + | FIX→ | |
| + | |||
| + | enable apache proxy module: | ||
| + | |||
| + | sudo a2enmod proxy | ||
| + | service apache2 restart | ||
| − | |||
| − | |||
| − | |||
| − | + | ''' | |
| − | the server responded with a status of 404 | + | Blank page (Empty page of death OR white page). When use the browser console, find error: (Browser) |
| − | + | the server responded with a status of 404''' | |
| + | FIX→ | ||
| + | |||
| − | disable DEBUG= True in the local_settings.py and make it DEBUG= False | + | disable DEBUG= True in the local_settings.py and make it DEBUG= False* |
| − | |||
| − | + | ''' | |
| + | When restart apache, I get this error (In Terminal): | ||
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName | apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName | ||
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 | (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 | ||
| سطر 46: | سطر 57: | ||
Unable to open logs | Unable to open logs | ||
Action 'start' failed. | Action 'start' failed. | ||
| − | The Apache error log may have more information. | + | The Apache error log may have more information'''. |
| + | |||
FIX→ | FIX→ | ||
Uninstall nginx related packages that use port 80. If you are using apache server | Uninstall nginx related packages that use port 80. If you are using apache server | ||
| − | |||
| − | + | ||
| + | '''error apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName''' | ||
| + | |||
FIX→ | FIX→ | ||
| − | + | add this line ⇒ | |
| + | ServerName localhost | ||
to the end of the file /etc/apache2/apache2.conf then restart the apache | to the end of the file /etc/apache2/apache2.conf then restart the apache | ||
| − | /etc/init.d/apache2 restart | + | /etc/init.d/apache2 restart |
| − | + | ||
| + | |||
| + | ''' | ||
| + | apache2: Syntax error on line 236 of /etc/apache2/apache2.conf: Syntax error on line 53 of /etc/apache2/sites-enabled/pandora.com: Expected </Location> but saw </VirtualHost> (Terminal)FIX→ | ||
| + | ''' | ||
| − | + | edit the file /etc/apache2/sites-enabled/pandora.com and remove line 4 that include the extra tag <Location /> save and restart apache | |
| − | + | /etc/apache2/sites-enabled/pandora.com gvim | |
| − | |||
| − | |||
| − | + | '''server not found (Error loading page) (Browser)''' | |
FIX→ | FIX→ | ||
| سطر 73: | سطر 89: | ||
run → ./manage.py runserver | run → ./manage.py runserver | ||
If did not switch to pandora user, will get the error: | If did not switch to pandora user, will get the error: | ||
| − | |||
| − | + | ||
| + | |||
| + | '''OperationalError: FATAL: Peer authentication failed for user "pandora"''' | ||
FIX→ | FIX→ | ||
su pandora | su pandora | ||
| − | |||
| − | + | ||
| + | '''Sorry, you have made an unauthorized request. (Browser) error when try to access anything like (add new list, manage users). Although I signed up 1st account to be admin''' | ||
FIX→ | FIX→ | ||
| + | comment the line that has | ||
| + | SESSION_COOKIE_DOMAIN in local_settings.py | ||
| − | |||
| − | |||
12- IOError: [Errno 26] Text file busy: './bin/python' django (Terminal) when run: | 12- IOError: [Errno 26] Text file busy: './bin/python' django (Terminal) when run: | ||
virtualenv --system-site-packages . | virtualenv --system-site-packages . | ||
| − | FIX→ | + | FIX→ should not apply virtual env packages after installation |
| + | |||
| + | 13- login failed! check config (Terminal) | ||
| + | pandora_client config | ||
| + | Current Config: | ||
| + | user: admin | ||
| + | pwd: admin | ||
| + | URL: http://localhost/api/ | ||
| + | Leave empty to keep current value | ||
| + | configuration updated. | ||
| + | ⇒ After running pandora_client config | ||
| + | You can check ~/.ox/client.json | ||
| + | It should looks like the following lines: | ||
| + | 1 { | ||
| + | 2 "username": "admin", | ||
| + | 3 "url": "http://localhost/api/", | ||
| + | 4 "cache": "~/.ox/client.sqlite", (temporary db)(local db) | ||
| + | 5 "media-cache": "~/.ox/media", (temporary store) | ||
| + | |||
| + | 6 "volumes": { | ||
| + | 7 "pandora_images": "/home/wafaa/Videos/" | ||
| + | 8 }, | ||
| + | 9 "password": "admin" | ||
| + | 10 } | ||
| + | pandora@ADEF-Wafaa:/home/wafaa/Videos$ pandora_client scan | ||
| + | |||
| + | |||
| + | http://arabdigitalexpression.org/wiki/Pandora_Installation_and_Configuration_Issues | ||
| + | |||
| + | admin user of pandora server | ||
| + | pwd of it | ||
| + | the local_settings.py should look like that: | ||
| + | |||
| + | DATA_SERVICE = 'http://localhost/api/' | ||
| + | VIDEO_PREFIX = "//localhost" | ||
| + | #SESSION_COOKIE_DOMAIN = ".localhost" | ||
| + | |||
| + | 1st time you run pandora_client config you add a path to tell pandora_client to read files from it and label this folder path | ||
| + | pandora_client add_volume name path | ||
| + | eg: pandora_client add_volume pandora_images /home/wafaa/Videos | ||
| + | → create folders tree with at least 2 levels under /home/wafaa/Videos | ||
| + | So it looks like | ||
| + | /home/wafaa/Videos/vids_for_pandora/pandora_camps_videos | ||
| + | /home/wafaa/Videos/vids_for_pandora/pandora_deca_videos | ||
| + | These folders suppose to have videos files .webm | ||
| + | Run the commands: | ||
| + | pandora_client scan | ||
| + | pandora_client sync | ||
| + | pandora_client upload | ||
| + | → Check https://wiki.0x2620.org/wiki/pandora_client for more details | ||
| + | without port 8000. This is only 4 dev server (it is virtual server) | ||
| + | NOTICE | ||
| + | 1 → Remove port 8000 from many config. Make virtual server for my pandora site. Access it through http://localhost | ||
| + | 2 → nginx is preferred to apache. May be cuz handles clean url (aliases) more than apache | ||
| + | 3- Remember to restart the server after changing any config | ||
| + | |||
| + | 14- RELATED ERROR: | ||
| + | {u'status': {u'text': u'login required', u'code': 401}} (Terminal) | ||
| + | |||
| + | DATA_SERVICE = 'http://localhost/api/' | ||
| + | VIDEO_PREFIX = "//localhost" | ||
| + | #SESSION_COOKIE_DOMAIN = ".localhost" | ||
| + | |||
| + | |||
| + | 16- Video is not playing in the browser and gives error file is corrupted although when I run mplayer from the terminal, I get the video working. I’m using Apache server. | ||
| + | |||
| + | FIX | ||
| + | ==== | ||
| + | I installed nginx, deleted default file in the /etc/nginx/sites-enabled and everything is working. | ||
| + | |||
| + | 17- When check log, I get | ||
| + | /var/log/nginx/pandora.access.log 404.html" failed (13: Permission denied) | ||
| + | |||
| + | → Make sure you are logged in or make video public | ||
| + | |||
| + | → Make the local_settings.py config looks like this: | ||
| + | DATA_SERVICE = 'http://localhost/api/' | ||
| + | VIDEO_PREFIX = "//localhost" | ||
| + | #SESSION_COOKIE_DOMAIN = ".localhost" | ||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | |||
| − | + | </div> | |
المراجعة الحالية بتاريخ 12:02، 1 مارس 2019
Loading screen after installation:
FIX→
uninstall rabbitmq and install it again
2- ImportError: No module named mongoengine.django.sessions (IN Terminal)
FIX→
run requirements.txt again. This error is the cause of not properly installed django and django extensions in the dir /srv/pandora/src
⇒ cd /srv/pandora run ./bin/pip install -r requirements.txt
- ERROR: Site pandora does not exist! when run a2ensite pandora (Terminal)
(step b) in README file for pandora installation tutorial in the wiki https://wiki.0x2620.org/browser/pandora/README) FIX→
rename pandora.conf to be pandora.com /etc/apache2/sites-available
cd /etc/apache2/sites-available mv pandora.conf pandora.com
then enable the new config file by running
a2ensite pandora.com
Syntax error on line 22 of /etc/apache2/sites-enabled/pandora.com: (Termial)
Invalid command 'ProxyRequests', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information ...fail
FIX→
enable apache proxy module:
sudo a2enmod proxy service apache2 restart
Blank page (Empty page of death OR white page). When use the browser console, find error: (Browser)
the server responded with a status of 404 FIX→
disable DEBUG= True in the local_settings.py and make it DEBUG= False*
When restart apache, I get this error (In Terminal):
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down Unable to open logs Action 'start' failed. The Apache error log may have more information.
FIX→
Uninstall nginx related packages that use port 80. If you are using apache server
error apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
FIX→
add this line ⇒
ServerName localhost
to the end of the file /etc/apache2/apache2.conf then restart the apache
/etc/init.d/apache2 restart
apache2: Syntax error on line 236 of /etc/apache2/apache2.conf: Syntax error on line 53 of /etc/apache2/sites-enabled/pandora.com: Expected </Location> but saw </VirtualHost> (Terminal)FIX→
edit the file /etc/apache2/sites-enabled/pandora.com and remove line 4 that include the extra tag <Location /> save and restart apache /etc/apache2/sites-enabled/pandora.com gvim
server not found (Error loading page) (Browser)
FIX→
cd /srv/pandora/pandora
su pandora run → ./manage.py runserver If did not switch to pandora user, will get the error:
OperationalError: FATAL: Peer authentication failed for user "pandora"
FIX→
su pandora
Sorry, you have made an unauthorized request. (Browser) error when try to access anything like (add new list, manage users). Although I signed up 1st account to be admin
FIX→ comment the line that has
SESSION_COOKIE_DOMAIN in local_settings.py
12- IOError: [Errno 26] Text file busy: './bin/python' django (Terminal) when run:
virtualenv --system-site-packages .
FIX→ should not apply virtual env packages after installation
13- login failed! check config (Terminal) pandora_client config Current Config: user: admin pwd: admin URL: http://localhost/api/ Leave empty to keep current value configuration updated. ⇒ After running pandora_client config You can check ~/.ox/client.json It should looks like the following lines:
1 {
2 "username": "admin",
3 "url": "http://localhost/api/",
4 "cache": "~/.ox/client.sqlite", (temporary db)(local db)
5 "media-cache": "~/.ox/media", (temporary store)
6 "volumes": {
7 "pandora_images": "/home/wafaa/Videos/"
8 },
9 "password": "admin"
10 }
pandora@ADEF-Wafaa:/home/wafaa/Videos$ pandora_client scan
http://arabdigitalexpression.org/wiki/Pandora_Installation_and_Configuration_Issues
admin user of pandora server pwd of it the local_settings.py should look like that:
DATA_SERVICE = 'http://localhost/api/' VIDEO_PREFIX = "//localhost"
- SESSION_COOKIE_DOMAIN = ".localhost"
1st time you run pandora_client config you add a path to tell pandora_client to read files from it and label this folder path pandora_client add_volume name path eg: pandora_client add_volume pandora_images /home/wafaa/Videos → create folders tree with at least 2 levels under /home/wafaa/Videos So it looks like /home/wafaa/Videos/vids_for_pandora/pandora_camps_videos /home/wafaa/Videos/vids_for_pandora/pandora_deca_videos These folders suppose to have videos files .webm Run the commands: pandora_client scan pandora_client sync pandora_client upload → Check https://wiki.0x2620.org/wiki/pandora_client for more details without port 8000. This is only 4 dev server (it is virtual server) NOTICE 1 → Remove port 8000 from many config. Make virtual server for my pandora site. Access it through http://localhost 2 → nginx is preferred to apache. May be cuz handles clean url (aliases) more than apache 3- Remember to restart the server after changing any config
14- RELATED ERROR: {u'status': {u'text': u'login required', u'code': 401}} (Terminal)
DATA_SERVICE = 'http://localhost/api/' VIDEO_PREFIX = "//localhost"
- SESSION_COOKIE_DOMAIN = ".localhost"
16- Video is not playing in the browser and gives error file is corrupted although when I run mplayer from the terminal, I get the video working. I’m using Apache server.
FIX
==
I installed nginx, deleted default file in the /etc/nginx/sites-enabled and everything is working.
17- When check log, I get /var/log/nginx/pandora.access.log 404.html" failed (13: Permission denied)
→ Make sure you are logged in or make video public
→ Make the local_settings.py config looks like this: DATA_SERVICE = 'http://localhost/api/' VIDEO_PREFIX = "//localhost"
- SESSION_COOKIE_DOMAIN = ".localhost"