| سطر 1: |
سطر 1: |
| | === نافذة البرنامج الرئيسية === | | === نافذة البرنامج الرئيسية === |
| − | عندما ستقوم بفتح إنكسكيب لأول مرة ستجد أمامك نافذة واحدة ولنتعرف عليها: | + | عندما ستقوم بفتح إنكسكيب لأول مرة ستجد أن واجهة البرنامج تتكون من نافذة واحدة ولنتعرف عليها: |
| | | | |
| | <nowiki>*</nowiki>1 | | <nowiki>*</nowiki>1 |
| | | | |
| − | ولنستعرض بشكل موما تشير إليه الأرقام في الصورة | + | ولنستعرض بشكل موجز ما تشير إليه الأرقام في الصورة |
| | # يُشير إلى شريط القوائم بالبرنامج وتضم القوائم كافة أوامر وخصائص البرنامج المعروضة بأشرطة الوصول السريع للأدوات والأوامر. وربما تكون مناسبة للمستخدم الجديد غير المعتاد على أماكن توزيع الأدوات والأوامر واختصاراتها في لوحة المفاتيح. | | # يُشير إلى شريط القوائم بالبرنامج وتضم القوائم كافة أوامر وخصائص البرنامج المعروضة بأشرطة الوصول السريع للأدوات والأوامر. وربما تكون مناسبة للمستخدم الجديد غير المعتاد على أماكن توزيع الأدوات والأوامر واختصاراتها في لوحة المفاتيح. |
| | # يُشير إلى شريط الأوامر، ويضم الأوامر الرئيسية كإنشاء مستند جديد وفتح مستند سابق وحفظ وطباعة الملفات واستيراد وتصدير الصور النقطية، وخيارات التراجع والمعاودة، وتكبير الكائنات المرسومة وتقريبها، وأوامر أخرى عديدة ومنها ما يتعلق بإظهار نوافذ التحكم في المستندات والطبقات وغير ذلك. | | # يُشير إلى شريط الأوامر، ويضم الأوامر الرئيسية كإنشاء مستند جديد وفتح مستند سابق وحفظ وطباعة الملفات واستيراد وتصدير الصور النقطية، وخيارات التراجع والمعاودة، وتكبير الكائنات المرسومة وتقريبها، وأوامر أخرى عديدة ومنها ما يتعلق بإظهار نوافذ التحكم في المستندات والطبقات وغير ذلك. |
| سطر 12: |
سطر 12: |
| | #* تستطيع رؤية وتعديل تفضيلات الأدوات من نافذة Preferences وتصل إليها من قائمة Edit أو عبر اختصار لوحة المفاتيح الآتي: Shift+Ctrl+P | | #* تستطيع رؤية وتعديل تفضيلات الأدوات من نافذة Preferences وتصل إليها من قائمة Edit أو عبر اختصار لوحة المفاتيح الآتي: Shift+Ctrl+P |
| | # شريط التحكم في خيارات الأدوات وتظهر فيه خصائص الأدوات، ولأن كل أداة لها خصائصها وخياراتها المميزة عن الأخرى فنرى أن الخيارات المعروضة بهذا الشريط تتغير عند النقر على أداة مختلفة.*4 | | # شريط التحكم في خيارات الأدوات وتظهر فيه خصائص الأدوات، ولأن كل أداة لها خصائصها وخياراتها المميزة عن الأخرى فنرى أن الخيارات المعروضة بهذا الشريط تتغير عند النقر على أداة مختلفة.*4 |
| − | # قماشة الرسم: وهي مساحة الرسم والتجريب التي نرسم عليها. | + | # رقعة الرسم: وهي مساحة الرسم والتجريب التي نرسم عليها. |
| | # صفحة الرسم: وتختلف عن السابقة في أن الرسومات المرسومة داخل حدودها الأربعة هي من تظهر في الملف النهائي المُصدر أو المطبوع. | | # صفحة الرسم: وتختلف عن السابقة في أن الرسومات المرسومة داخل حدودها الأربعة هي من تظهر في الملف النهائي المُصدر أو المطبوع. |
| | # المساطر: لنقيس أبعاد الرسم بدقة والمسطرة العلوية تسمى horizontal ، أما الجانبية فتسمى vertical ، وتستخدم تلك المساطر وحدة قياس pixels (النقاط) ويمكننا تغييرها إلى وحدات أخرى مثل السنتيمتر والمليمتر من نافذة Document Properties بقائمة File *5 | | # المساطر: لنقيس أبعاد الرسم بدقة والمسطرة العلوية تسمى horizontal ، أما الجانبية فتسمى vertical ، وتستخدم تلك المساطر وحدة قياس pixels (النقاط) ويمكننا تغييرها إلى وحدات أخرى مثل السنتيمتر والمليمتر من نافذة Document Properties بقائمة File *5 |
| سطر 20: |
سطر 20: |
| | # شريط لوحة الألوان: وسنرى أنه يمكننا أن نرسم أي شيء وفور الضغط بزر الفارة الأيمن على أحد الألوان في لوحة الألوان ستتم تعبئة هذا الشكل باللون المختار، أما إذا أردنا تعبئة حدود الشكل بلونٍ غير قلب الشكل فما علينا سوى الضغط على زر Shift ومن ثم النقر بزر الفأرة على اللون المختار. | | # شريط لوحة الألوان: وسنرى أنه يمكننا أن نرسم أي شيء وفور الضغط بزر الفارة الأيمن على أحد الألوان في لوحة الألوان ستتم تعبئة هذا الشكل باللون المختار، أما إذا أردنا تعبئة حدود الشكل بلونٍ غير قلب الشكل فما علينا سوى الضغط على زر Shift ومن ثم النقر بزر الفأرة على اللون المختار. |
| | #* يمكننا التبديل لألواحٍ لونية أخرى وذلك بالنقر على السهم الموجود أقصى يمين شريط لوحة الألوان لتنسدل قائمة بها العديد من الألواح لنختار منها. | | #* يمكننا التبديل لألواحٍ لونية أخرى وذلك بالنقر على السهم الموجود أقصى يمين شريط لوحة الألوان لتنسدل قائمة بها العديد من الألواح لنختار منها. |
| − | # شريط الحالة: ويعرض هذا الشريط العديد من البيانات مثل: لوني التعبئة والحد، ودرجة الشفافية، وحالة الرسم (مرئي أم مؤمن)، وطبقة الرسم الحالية، ومستوى التكبير الحالي للرسم، ومنطقة لإظهار التنبيهات والملاحظات المختلفة. | + | # شريط الحالة: ويعرض هذا الشريط العديد من البيانات مثل: لوني التعبئة والحد، ودرجة الشفافية، وحالة الرسم (مرئي أم مؤمن)، وطبقة الرسم الحالية، وحجم التقريب الحالي للرسم، ومنطقة لإظهار التنبيهات والملاحظات المختلفة. |
| | # ويستخدم هذا المقبض في تحجيم نافذة البرنامج بشكلٍ يدوي. | | # ويستخدم هذا المقبض في تحجيم نافذة البرنامج بشكلٍ يدوي. |
| | | | |
| | + | === تخصيص واجهة إنكسكيب === |
| | + | يُتيح إنكسكيب تخصيص واجهته لتناسب المصمم فعلى سبيل المثال عند الذهاب لقائمة View سنرى في نهاية القائمة المنسدلة ثلاث خيارات لشكل الواجهة كما بالصورة *7 |
| | + | |
| | + | وهو ما يوفر شكلًا يناسب الشاشات العريضة وآخر افتراضي وثالث يناسب الشاشات غير العريضة *8 |
| | + | * عبر المتحكمات المشار إليها في الصورة التوضيحية للواجهة يتم سحب الأشرطة بالضغط بزر الفارة الأيسر على تلك المتحكمات ومن ثم ترسيتها خارج موضعها لتكون حرة. |
| | + | |
| | === Dockable Dialogs === | | === Dockable Dialogs === |
| | + | يتوفر بإنكسكيب مجموعة من النوافذ الحوارية كنافذة الطبقات والمستندات والمحاذاة والتوزيع والنصوص، وغير ذلك ويمكننا إظهارها لتكون حرة أو نقوم بإرسائها في حوض على يمين واجهة البرنامج، ويظهر لنا عبر سحبه للداخل من مقبض التحكم الخاص به، وسيظهر فارغًا إلى أن نقوم بتعبئته بالنوافذ المختلفة كما بالصورة التالية *9 |
| | + | * يتم إرساء النوافذ في المرساة عن طريق الضغط بزر الفأرة الأيسر على لسان النافذة فيظهر أسفلها موضعها الفارغ بحوض إرساء النوافذ، ومع الاستمرار في الضغط وسحب النافذة إلى هذه المرساة حتى تظهر إطاراتها ومن ثم يتم إفلاتها بداخلها *10 |
| | + | |
| | + | * بإمكاننا وضع نافذة واحدة في المرساة أو عدة نوافذ متجاورة أو أسفل بعضها *11 |
| | + | ** يمكننا تصغير النوافذ لتوفير مساحتها ليظهر لسان منها في المرساة بالضغط عليه تتم استعادة النافذة لوضعها السابق، وذلك بالضغط على المثلث ذات القاعدة المقلوبة ناحية اليسار والموجود يمين لسان النافذة، كما يتم حذف النافذة من الحوض بالضغط على زر الغلق المجاور للمثلث بلسان النافذة كما بالصورة *12 |
| | + | ** لإلغاء عملية سحب وإفلات النوافذ في المرساة لتكون النوافذ حرة نستطيع تحريكها لأي موضع بالشاشة أثناء التصميم نقوم بسحبها من لسانها وإفلاتها خارج المرساة. أو لنتوجه إلى قائمة File ومن ثم نختار Inkscape Preferences وستظهر لنا نافذة خاصة بتفضيلات البرنامج ولنختار منها Windows لنتحكم في خصائص نوافذ البرنامج، وسنجد أسفل خاصية Dialog behavior خياريّ Dockable و Floating ولنختار الثاني ونعيد تشغيل البرنامج لنرى ما جد على النوافذ كما يظهر بالصورة التالية *13 |
| | + | ** ويمكننا إخفاء هذه النوافذ وإظهارها من خلال أمر View بقائمة Show/Hide Dialogs بالضغط على F12 |
| | + | [[تصنيف:إنكسكيب]] |